SharePoint 2013 – Isolated App domain setup issues – Make sure the web address http://apps-6967e27a413f60.xxx.abc.local:2014 is correct.

Today, I will talk about this weird issue which users get when they click on an app installed in SharePoint site- “Make sure the web address http://apps-6967e27a413f60.xxx.abc.local:2014 is correct.”

My client installed couple of apps from Office store which can be seen under ‘All site contents’ but when they click on any of the app they were welcomed with the page with the error message shown above. I spent lot of time to explore the probable cause of this, gone through many blogs such as this (http://sharepointchick.com/archive/2012/07/29/setting-up-your-app-domain-for-sharepoint-2013.aspx) to ensure that app domain is setup properly. I couldn’t find anything wrong with the setup on domain controller.

After some head scratching, I thought that it could be a SSL certificate issue. Logged in to IIS and found that SSL certificate was missing on the IIS to handle ‘https’  requests to the app domain. To fix this I had to create a wildcard SSL certificate for the app domain. When you create the certificate in IIS, make sure that certificate name is https://*.abcapps.com.au if the lookup zone for apps in DNS manager is “abcApps.com.au”.  Once the certificate is created, it should look something like this –

After the certificate is created, you need to add an extra binding to the IIS site which is the sharepoint site that has the apps installed. To add an extra binding to the site, select the site in IIS Manager and click ‘Binding’ under ‘Actions’ and create  a new binding with SSL certificate created above and should look something like this –

 

 

All done!!

Leave a Comment

Your email address will not be published. Required fields are marked *